[HM1] ХМ не прописывается в систему

    • elsabedor
      elsabedor
      Бронза
      На форуме с: 28.02.2008 Сообщения: 433
      На фоне текущих проблем с обновлениями винды, очень надеюсь, что мое проблема не останется без помощи. Суть проблемы такова.

      Поставил новую ОС - семерку. До этого она же и была, просто пришла пора освежить. После этого ставлю HM на чистую ОС и установленный postgre9, но ставится все коряво. Каждый раз выдает разного рода ошибки - преимущественно с файлом конфигурации. Проблема известная, и решается удалением ХМ из системы и новой установкой. НО! Ни штатными средствами винды, ни внешними прогами по деинсталяции обнаружить ХМ в системе не удается. То есть, папку он себе создает, через раз коряво запускается, но нигде в его в системе не видно. Что это за проблема может быть такая? Винда без самых последних обновлений, ХМ самый последний, уже пофиксенный - 1.11.07
  • 9 ответов
    • ExConfessor
      ExConfessor
      Супер-модератор
      Супер-модератор
      На форуме с: 21.08.2007 Сообщения: 37.028
      Если во время установки ХМ были ошибки, то мог и не прописаться.
    • elsabedor
      elsabedor
      Бронза
      На форуме с: 28.02.2008 Сообщения: 433
      Ну так я уже и сборки винды поменял, устанавливал/удалял несколько раз - результат тот же. Правда удалять приходится просто папку - иначе нечго и удалять, в системе то его нет. Не знаю что и делать...
    • elsabedor
      elsabedor
      Бронза
      На форуме с: 28.02.2008 Сообщения: 433
      Словом ведет себя ХМ следующим образом...

      Снова удалил и установил его. Он не прописался, а просто создал себе папку и туда стал. Запускаю. Выдает стандартную ошибку про Config. Не обращаю внимания, запускаю.Снова та же ошибка, снова игнор с моей стороны и наконец-то ХМ запущен. ОК, пытаюсь закрыть крестиком, но не закрывается. Иду в выход через меню, но при попытке выхода выдает снова проблему и снова про Config. C горем пополам закрывается. Дальше - интереснее...

      Запускаю ХМ снова. Теперь выдает ошибку иного плана - про ошибку пароля при аутентификации для пользователя postgre. Причем самое интересное, что пользователь со старой PostgreSQL - имя тогда еще с ошибкой ввел "posgtre", так что не спутать. Жму ок, пытаюсь подключиться к базе данных. По новому пользователю postgre уже подключаться не хочет. Пробую логин и пароль от старого пользователя - подхватывает и запускается. Правда по пути снова выдает кучу ошибок про Config, но в итоге ХМ запускается. Что самое интересное, что база в ХМ старая - еще до сноса и переустановки винды. В этот раз создавал базу с иным именем. Такое впечатление, что где-то остались куски старого postgre и весь сыр бор из-за его конфликта с новым.

      Диспозиция по postgre такова... Ранее стояла версия 8.3, и стояла она не на системном диске. По сути когда переустановил винду, удалил ее тупо в лоб, так как в системе она оказалась не прописана. Просто удалил папку с ней.В это раз установил версию postgre 9, но устанавливал уже по уму - саму прогу на системный диск, а базу на другой (там где раньше стояла вся postgre 8.3). Словом вот такая петрушка. Помогите пожалуйста советом, как развязать этот клубок.
    • Morpheuzis
      Morpheuzis
      Золото
      На форуме с: 03.09.2009 Сообщения: 3.316
      что-то у тебя все не прописано, но все работает.
      Посмотри в реестре (в службах), какие версии постгри у тебя работают и запускаются. (можно посмотреть тут )
      Про конфиг. Попробуй дать полные права на папки ХМ.
      И еще.
      Попробуй при установке выбирай "запуск от имени администратора".
    • elsabedor
      elsabedor
      Бронза
      На форуме с: 28.02.2008 Сообщения: 433
      Старая версия (8,3) в реестре не обнаружена.

      Доступ на папки ХМ дал.

      При установке запускал от имени администратора.
    • elsabedor
      elsabedor
      Бронза
      На форуме с: 28.02.2008 Сообщения: 433
      Удалил постгре. Удалил ХМ. Решил попробовать ставить ХМ на систему без постгре, чтоб сам для себя устанавливал. Ничего подобного - просто создал папку куда и распаковался, в систему не прописался, постгре не создал.
    • Shady1988
      Shady1988
      Бронза
      На форуме с: 03.12.2008 Сообщения: 341
      попробуй удалить хм с постгре полностью и установить все это комбо инсталером
    • elsabedor
      elsabedor
      Бронза
      На форуме с: 28.02.2008 Сообщения: 433
      Комбо инсталлером? Whats this?
    • ExConfessor
      ExConfessor
      Супер-модератор
      Супер-модератор
      На форуме с: 21.08.2007 Сообщения: 37.028
      Удали хвосты от предыдущих установок ХМ с помощью Revo Uninstaller и хвосты постгре по инструкции.

      Затем скачай комбо-инсталлер (ХМ+постгре в одном флаконе) и установи. Вот ссылка.