В целях облегчения навигации по сайту используются Cookie-файлы. Продолжая просмотр сайта, вы принимаете указанные Cookie-файлы. Для получения дополнительной информации и изменения настроек ознакомьтесь с политикой Cookie и политикой конфиденциальности. Закрыть

[HM1] Postgres 9.1

    • Bodrello
      Bodrello
      Бронза
      На форуме с: 27.09.2009 Сообщения: 1.044
      Всем привет!

      Пытаюсь перейти с HM1 на HM2 и заодно решил обновить Postgres c 8.4 на 9.1. Вопрос такой:

      Почему когда заходишь в pgAdmin III там две группы серверов? Одна на англ., а вторая на русском. Причём одна открылась без пароля (англ.), а вторая запросила пароль. И в той и в другой группе одинаковые базы.

      И почему называется и та и другая группа PostgreSQL 8.4 (localhost:5432), хотя я поставил Postgres 9.1?

      Перед тем как ставить 9.1 я снёс 8.4 и перезагрузился.
  • 6 ответов
    • ExConfessor
      ExConfessor
      Супер-модератор
      Супер-модератор
      На форуме с: 21.08.2007 Сообщения: 37.475
      1. Лучше бы скриншот показал.
      2. Видимо плохо снес.
    • Bodrello
      Bodrello
      Бронза
      На форуме с: 27.09.2009 Сообщения: 1.044
      Про скриншот сразу не сообразил. Исправляюсь)



      Так у меня получается сейчас база на версии 8.4 стоит?

      ЗЫ Сносил по инструкции. Правда как там написано про командную строку не получилось сделать. Фигню какую-то выдало. Сейчас не помню, но что-то типа описания чего то.
    • vpmarat
      vpmarat
      Модератор
      Модератор
      На форуме с: 22.01.2008 Сообщения: 84.663
      9.1 не рекомендуется пока для ХМ. По крайней мере, на нем он не тестился.
      А по скрину получается, что у тебя таки остался 8.4
      ты попробуй до уровня таблиц в базе добраться по дереву и посмотреть данные в одной из
    • Morpheuzis
      Morpheuzis
      Серебро
      На форуме с: 03.09.2009 Сообщения: 3.316
      Забей. Плохо снес, просто. Так тоже можно жить.
      Или можешь посмотреть в этот разделе, что у тебя там?
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\postgresql-8.4
      если их два похожих, то сделай бекап одного и удали. Если постгри не запустится, то восстанови удаленный и удали другой.

      p.s. еще можешь удалить через ПГАдмин (сам сервер), правда я не знаю, какой из них правильный :grin:
    • Bodrello
      Bodrello
      Бронза
      На форуме с: 27.09.2009 Сообщения: 1.044
      Действительно плохо снёс!) Сегодня переустанавливал систему, установил 9-й постгресс.... Всё ОК встало. Теперь 9.1 пишет)
    • vpmarat
      vpmarat
      Модератор
      Модератор
      На форуме с: 22.01.2008 Сообщения: 84.663
      Ну вот и разобрались
      Закрыто