В целях облегчения навигации по сайту используются Cookie-файлы. Продолжая просмотр сайта, вы принимаете указанные Cookie-файлы. Для получения дополнительной информации и изменения настроек ознакомьтесь с политикой Cookie и политикой конфиденциальности. Закрыть

Актуальная версия postgres для Holdem manadger 2

    • barobama
      barobama
      Бронза
      На форуме с: 20.05.2011 Сообщения: 851
      Ось ХР, сервис пак 2, Нoldem menedger 2.
      Какую Постгресс ставить? в комплекте стоит как я понимаю 8.4, но из комплекта она не устанавливается. Говорит что установка прервана. в чем проблема не пойму. служба вторичного входа в систему включена. устанавливаю по стандарту (пути не меняю, все пути на латинице, имя пользователя на латинице, имя компьютера на латинице).
      Ранее ставил постгрес 8.4 и не получилось подключиться к базам. Хочу попробывать поставить версию 8.3, по ней подробная инструкция. Будет на ней работать НМ2?
  • 18 ответов
    • OldGambler
      OldGambler
      Бронза
      На форуме с: 27.10.2010 Сообщения: 3.870
      Риторический вопрос к модераторам: может сделать видео по установке postgres?
    • dooGie
      dooGie
      Бронза
      На форуме с: 05.11.2006 Сообщения: 2.127
      я поставил 9.0 - на 8.4 не импортировалось (именно у меня)
    • barobama
      barobama
      Бронза
      На форуме с: 20.05.2011 Сообщения: 851
      У меня ось ВИН ХР, на него как я понимаю только 8.4 идет, все что выше уже для 32х и 64х разрядных систем.
    • barobama
      barobama
      Бронза
      На форуме с: 20.05.2011 Сообщения: 851
      Ну кто нибудь знает? можно Постгри 8.3 ставить для НМ2?
    • vpmarat
      vpmarat
      Модератор
      Модератор
      На форуме с: 22.01.2008 Сообщения: 84.443
      ХМ2 будет работать с любой Постгри, даже 8.2
      но под 9.1 в частности - почти не тестировался.
      та 8.4.7, которая в инсталяторе ХМ, должна становиться "влёт".
      Если нет - раскажи подробнее, что за ошибки. С картинками

      и имей в виду все это
      Если операционная система Вин7 (или Виста), следует иметь в виду все это:
      1) Имя компьютера должно быть на английском и "в одно слово" (без пробелов) - после изменения требуется перезагрузка
      2) Имя пользователя Виндовс - аналогично. Если это не так, следует создать нового пользователя с английским именем, дать ему права администратора и перегрузить компьютер под него. Затем установить Postgres и ХМ, после чего снова перегрузить комп - обратно под старого пользователя, а этого можно будет удалить - его миссия завершена.
      3) Служба "Вторичный вход в систему" должна быть установлена на "Автостарт". Панель управления - администрирование - Службы.
      4) Контроль учетных записей UAC надо выключить.
      ( http://www.mydigitallife.info/2008/12/30/how-to-disable-and-turn-off-uac-in-windows-7/ )
      5) При установке Postgres и ХМ рекомендуется выключить антивирус и файерволл. Или совсем их деинсталлировать на это время.
      6) Все установки обязательно запускать "от администратора" (по правому клику на файл) - невзирая на то, что у пользователя Виндовс права администратора, как правило, имеются. И желательно запускать установки первым делом после перезагрузки компа.
      7) Если есть необходимость устанавливать Postgres не в папку по умолчанию (см следующий пункт), или использовать неумолчальную папку для базы данных - следует скачать отдельный установщик http://www.enterprisedb.com/products-services-training/pgdownload#windows (при выборе версии 9.0 над брать ту, что соответствует разрядности Виндовс на компе).
      8) Если Виндовс не на английском - устанавливать Postgres следует именно не в умолчальную папку. Требуется создать в корне диска (например) папку и ставить программу в нее.
      9) Устанавливать Postgres и ХМ надо отдельно, по очереди. От админа. Когда ХМ после первого запуска сообщит, что отстуствует база данных - просто создать ее через DBControlpanel.exe (для ХМ1). В ХМ2 установочный визард сам скажет, что нужно делать.
      10) После каждой неудачной попытки установки Postgres следует не только её деинсталлировать через Панель управления, но и удалить из системы пользователя по имени "postgres":
      "Пуск", "Выполнить", набрать с клавиатуры "cmd" и по правому клику запустить командную строку от админа
      В черном окне набрать без ошибок следующую команду (и нажать Enter):
      net user postgres /del
      Должно появиться сообщение, что команда выполнена успешно. Для проверки набрать
      net user
      (без параметров) - получим список пользователей, в котором не должно быть пользователя postgres
      11) Кстати, все клиенты покер-румов также должны запускаться "от админа"
    • barobama
      barobama
      Бронза
      На форуме с: 20.05.2011 Сообщения: 851
      Получается что единственное что я делал не так, это не запускал установщик от админа. То есть запускал от пользователя с правами админа. Сейчас попробую установить от админа.
      Еще я не очень понял вы пишете: надо отдельно установить Постгри, а потом НМ2, но при этом вы же пишете, что из пакета последнего установщика НМ2 все должно установиться влет. В общем еще раз попробую от админа запустить общий установщик НМ2.
      Еще один вопрос про виндоус. У меня Виндоус ХР, тут АUC нету. все везде названо латиницей. Но сама ось понятно русская. Имеет ли это значение? Уточняю, все названия папок и файлов, на которые ссылается программа все равно латинские. (c:programm files... )
    • vpmarat
      vpmarat
      Модератор
      Модератор
      На форуме с: 22.01.2008 Сообщения: 84.443
      Если винХР - там вообще все просто должно быть. И понятия "запуск от админа" под ХР просто нету.
      А писал про раздельную установку именно для тех случаев, когда сразу не ставится - но такое обычно на вин7 происходит.
    • barobama
      barobama
      Бронза
      На форуме с: 20.05.2011 Сообщения: 851
      и все равно не вышло ничего ((
      вот скрины:
      http://s019.radikal.ru/i607/1203/47/12b5f0473951.jpg
      http://s019.radikal.ru/i600/1203/a5/05e5db0aa5a6.jpg
      http://s019.radikal.ru/i601/1203/3a/5992d48c3fca.jpg
      http://s55.radikal.ru/i147/1203/b9/52fa02a95a51.jpg
      http://s019.radikal.ru/i620/1203/8e/9094d7f61890.jpg
    • barobama
      barobama
      Бронза
      На форуме с: 20.05.2011 Сообщения: 851
      В свое время когда устанавливал слона, даже не задумывался о этих ПОСТГРИ, может стоит еще раз попробывать установить слона, чтобы он установил постгри. только в этот раз все сделать на диск С и без изменений имени пользователя и пароля...
    • barobama
      barobama
      Бронза
      На форуме с: 20.05.2011 Сообщения: 851
      нихрена не пойму. Установил слона, он все еще помнит меня и мою старую базу... все ники узнал. Только теперь и он вылетает в течении минуты и коннект с базой поределить не может и создать новую не может, но предлагает старую базу, с которой тоже коннек не тянет... походу проще мне будет снести ось и ставить все по-новой...
    • barobama
      barobama
      Бронза
      На форуме с: 20.05.2011 Сообщения: 851
      ну в общем по реестру прошел вдоль и поперек, удалил все разделы и строки с упоминанием postgr, elephan, holdem, hero, так же прошелся с поиском по файловой системе, все удалил.
      Установил Постгри 8.3, установил НМ2 и все равно такая попа:
      http://i027.radikal.ru/1203/1f/66d3f29277d1.jpg
      не пойму что не так делаю...
      Уже просто в бешенстве на все эти программы. Как то возможно обратиться в суппорт от НМ2 русскоязычный? или у них только на английском?
      Вот скрины от PGaadmin:
      http://s019.radikal.ru/i642/1203/29/6348e081810f.jpg

      Странно, что раньше, когда все работало от слона, в диспетчере задач было куча процессов postgre, сейчас же нет ни одного...

      Вот что пишет в окне запуска процесса Постгри
      http://s019.radikal.ru/i618/1203/a1/e3a00f4e57e3.jpg
    • vpmarat
      vpmarat
      Модератор
      Модератор
      На форуме с: 22.01.2008 Сообщения: 84.443
      без сеанса по Тимвьюевру, похоже, не обойтись
    • barobama
      barobama
      Бронза
      На форуме с: 20.05.2011 Сообщения: 851
      Итак сегодня сношу ось, после установки чистой оси, первым делом буду ставить НМ2 . То есть буду устанавливать от НМ2 дистрибутива и Постгри. Я так понимаю ничего не должно помешать установить пакету. Если что то не так, то придется писать в тех поддержку НМ2
    • vpmarat
      vpmarat
      Модератор
      Модератор
      На форуме с: 22.01.2008 Сообщения: 84.443
      но сначала сделай это
      Убедиться, что Виндовс полностью обновлена - до состояния "критических обновлений больше нет".
      Включая Internet Explorer (даже, если пользоваться им не планируется).
      Удалить все имеющуеся версии NetFramework с помощью этого: http://videos.holdemmanager.com/dotnetfx_cleanup_tool.zip
      Далее - скачать инсталлятор NET и запустить
      для XP / Vista - сначала 3.5 sp1 http://download.microsoft.com/download/2/0/e/20e90413-712f-438c-988e-fdaa79a8ac3d/dotnetfx35.exe
      а затем и NET4 (если дело касается ХМ2. Для ХМ1 под XP достаточно 3.5 sp1)
      для Win7 - только NET4 (для всех версий ХМ) http://www.microsoft.com/downloads/en/details.aspx?FamilyID=9cfb2d51-5ff4-4491-b0e5-b386f32c0992&displaylang=en
      После инсталляции каждой версии NET - повторно обновить Виндовс (там всегда появляются новые критические обновления).
      И каждый раз, когда Виндовс просит перегрузиться - делать это сразу, не откладывая "на потом".
    • barobama
      barobama
      Бронза
      На форуме с: 20.05.2011 Сообщения: 851
      с эти сложнее, винда не хочет много обновляться через инет. только с диска (но там обновление до СП3). причину не хотелось бы произность вслух
    • vpmarat
      vpmarat
      Модератор
      Модератор
      На форуме с: 22.01.2008 Сообщения: 84.443
      Гарантии, что на ворованной Виндовс ХМ будет работать, нету.
      Но по крайней мере, поставить NET все равно обязательно - это даже украденная винда позволяет.
    • Vovanreg
      Vovanreg
      Бронза
      На форуме с: 25.02.2010 Сообщения: 15
      У меня винда ХР с SP2 правда лицензия. ХМ работает с постгри 8,3. на 8,4 из установочного пакета не хочеть работать. пишет что не может подключиться к базе. А NET надо ставить иначе тоже работать не хочет.

      обновлений последних не ставил. Просто потому что когда раз попробовал, то через некоторое время (совсем маленький промежуток ) винда слетела.
    • vpmarat
      vpmarat
      Модератор
      Модератор
      На форуме с: 22.01.2008 Сообщения: 84.443
      Первое требоваие саппорта в случае проблем с ХМ - привести винду к состоянию "критических обновлений больше нет". А если XP - обязательно чтобы СП3